Maintenance
Incident Report for Galaxypedia
Postmortem

Maintenance is basically finished. I've managed to get a functional version of the Galaxypedia onto a docker image. This is revolutionary because it means that in order to run the Galaxypedia the only thing you need is that docker image. This also means that the Galaxypedia could potentially stay up during maintenance as I would simply build the docker image on my VPS, send it to another machine (prob my home laptop), run the Docker container, go onto cloudflare and change DNS to point to the new temporary IP, and done.

Only issue is that the Galaxypedia uses sqlite as a database and you can't remotely update an sqlite database since sqlite isn't supposed to be edited by multiple processes at the same time. Which sucks because it means that if I actually wanted to run the Galaxypedia on something like kubernetes (for non IT nerds: i basically load balance the Galaxypedia along multiple servers, so if a server goes down the other one can stay up as the backup & requests are split evenly across the servers)

Also I did kinda create the image using a process which is considered bad practice so it needs some fine tuning. But hey, it works.

Posted May 24, 2022 - 01:37 EDT

Resolved
The Galaxypedia was undergoing tests.
Posted Apr 26, 2022 - 11:30 EDT