Infrastructure Upgrade
Incident Report for Galaxypedia
Postmortem

I have upgraded my server from the latest ubuntu development release (21.10) to the newer 22.04 LTS. The good news about this is that I will not have to update my server for the next 5 years. So this is likely the last update my server will be seeing for a while.

The Galaxypedia was down for a bit longer as I wished to enable end-to-end encryption on all sites in the robloxgalaxy.wiki domain. The current configuration allows for the possibility of a man-in-middle attack to occur, which does not sit very well with me. I want all users of the Galaxypedia to feel safe using and accessing the site, so end-to-end encryption is a must-have. This has since been implemented.

Posted May 24, 2022 - 01:52 EDT

Resolved
Scheduled Maintenance was conducted starting from 3:00 EST to upgrade the servers to a new ubuntu release.
Posted May 15, 2022 - 17:00 EDT