Database Migration
Incident Report for Galaxypedia
Postmortem

What's changed? To put it simply I migrated the database to a new engine which is more flexible. However because I had to manually transfer the data, it results in minor data loss which you can quickly notice (ex. your watchlist was wiped). You might also notice that page history is a bit weird. However they'll fix themselves given time.

When you first navigate onto the website, it will look a bit weird and you'll notice that you're logged out. Log in and quickly change your password, can't emphasize this enough. Change your password!!! The chances of you being hacked from this database transfer are slim (as all of your personal info are end to end encrypted) but still, it's best to change your password.

Also what does this mean about talk pages? Oh they're coming real soon! This new database update will let us optimize talk pages and make them somewhat similar to Fandom talk pages. The only thing I need to do before releasing talk pages is to train my staff to moderate talk pages.

Thank you all for your patience, I deeply apologize for how long it took me to go through with the maintenance but as you've read in the outage logs, it was a very rough process. I hope you enjoy the new and improved Galaxypedia which boasts better index times, new features, and much more to come!

Posted May 24, 2022 - 01:34 EDT

Resolved
The Galaxypedia went down from April 29th to May 2nd 2022. The incident was caused by planned database migration from sqlite to mysql.
Posted Apr 29, 2022 - 12:00 EDT