Infrastructure Upgrade & Unplanned Outage
Incident Report for Galaxypedia
Postmortem

An extremely serious issue was discovered in the server running the Galaxypedia prior to the server upgrade. The server was completely broken as a result of this issue. This extended the duration of the outage. Fortunately yname helped me in restoring the server and preventing data loss. The issue has been fixed (it took hours & we were genuinely scared we’d lose the data on the server) and my server has been upgraded.

The server upgrade had also upgraded a dependency of the Galaxypedia, PHP, which was patched later on but added to the duration of the outage.

Posted May 24, 2022 - 01:41 EDT

Resolved
Infrastructure Upgrade turned into an unplanned outage as infrastructure started breaking.
Posted Apr 21, 2022 - 10:30 EDT